#96 ✓resolved
Stephen Bannasch

problem editing English.lproj/Preferences.xib

Reported by Stephen Bannasch | February 10th, 2009 @ 03:28 AM

When I open English.lproj/Preferences.xib in Interface Builder, make no changes, and then save the file it appears to get corrupted. When I re-open the file I get this error dialog from IB:

Unable to resolve plug-in dependency for "Preferences.xib".
Locate the {{211, 334}, {400, 74}} Interface Builder plug-in
to continue opening this document. Press "continue" to continue
opening without resolving the dependency.

this is an example of an invalid string that is added to the IBDocument.PluginDependencies element:

<string>{{211, 334}, {400, 74}}</string>

You can see a git diff of the differences here: http://gist.github.com/61191

I am using IB v3.1.2 (677) on MacOS 10.5.6

Comments and changes to this ticket

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

GitX is the nice-looking gitk clone for OS X

People watching this ticket

Pages